Errors and slow responses from the Nx API

Incident Report for Nx

Resolved

The Nx API is back to operating as normal. Please restart any pipelines that were disrupted, we apologize for any inconvenience caused.
Posted May 11, 2026 - 23:22 UTC

Update

The issue has been identified and a fix has been issued, we are waiting a few more minutes to verify that the Nx API is healthy.
Posted May 11, 2026 - 23:18 UTC

Update

We are continuing to investigate this issue.
Posted May 11, 2026 - 23:14 UTC

Investigating

We've received alerts about a high number of errors and slow response times on the Nx API. The team is investigate a fix.
Posted May 11, 2026 - 23:07 UTC
This incident affected: Nx API and Nx Cloud Agents.